Topaz Studio Changelog

How do I update?

Select Help → Check for Updates to start the update process

updateMac.png

Select Help → Check for Updates to start the update process

updateWin.png
 Update failed?

If this process fails, you will need to reinstall, using the Topaz Studio Installer from the Downloads Page:

Lens Profile Database

LensFun v0.3.2

 More info

RAW Processing Library

LibRaw v0.17

 More info
The   symbol denotes a Cumulative Update, marking several changes from the previous version. These are big updates!
The   symbol denotes the current public release version.

Topaz Studio v1

1.0.4

First Public Release of Topaz Studio

June 6, 2017
  • Improved the performance issue in v1.0.3
  • Low image quality after saving the result
  • Image Layer and Apply makes a line in flattened image

1.0.5

June 8, 2017
  • Save Image options dialog
  • TIFF files saved in TS cannot be opened or looks corrupted by PS
  • TIFF files saved from .NEF RAW file in TS cannot be opened in Nikon Software
  • Topaz Studio are not installed to PS CC for some MacOS Sierra users

1.0.6

June 21, 2017
  • Healing/Spot Removal tool
  • Image horizonal and vertical flip
  • On-screen manipulation for texture
  • Added Image menu with Image rotation and flipping menu items
  • Removed Image Orientation from Crop tool
  • Added a public/private field to the Effect Info section
  • For low-end graphics card, the input image size in PS and TS does not match
  • Topaz Studio "Not Responding" on display with large scaling settings
  • on Mac, crop tool on-screen control does not follow mouse movement
  • Adjustment level topaz preset can be deleted by user
  • Cannot like my effect
  • When opening the edit effect dialog, the Public/private toggle button is always set to private (even when my effect is public)
  • Sync Adjustment feature needs status notification
  • Effects sometimes have blank names and show up in All at the top
  • No results found message always shows search text in lower case (regardless of what was passed in)

1.0.7

June 23, 2017
  • Adjustments are disabled when Healing, Cropping, Lens Correction, and Masking tools are in use.
  • Auto Lens Correction for RAW files not working

1.0.8

July 7, 2017
  • Added ability to resize images
  • Added ability to open multiple images in Photoshop plugin mode
  • When a new document is created, that document becomes the current document in workspace
  • Added a "Shop Pro Adjustments" menu item
  • Added Duplicate and Apply menu item under the Image menu
  • Added a "Thank you for sharing" toast message
  • Application hangs/freezes when selecting "All" and "Trending" tags
  • Preview Image Hi-DPI support
  • Navigator zoom level did not match the image preview zoom level
  • Fit for a portrait image caused the top/bottom of the image to be cut off
  • Get Info panel in Mac version said "Created by Qt/QMake" in version number
  • Adjustment Reset was consistently incorrect
  • Clicking Mine did not show all effects I've created, but searching for my user name did.

1.0.9

July 20, 2017
  • User can share images to Facebook
  • User can add custom aspect ratios in Cropping tool
  • Added an option to use Percentage to resize image
  • Added an option to adjust the color theme by entering the hex values of a color
  • Added Healing to Tools Dropdown Menu in Application Menu
  • Installer will not display the OpenGL check result if passed the check
  • Switched film grain strength/size slider position
  • Removed the limitation on number of presets in a category, limited to 300 in v1.0.8
  • Image in Heal and Lens tool remained in the preview even after newly selecting other image
  • Using Simplify (and Adjust, ReStyle) as a plugin within TS causeed the program to crash
  • Fixed Color Theme slider inconsistency issue
  • Lens search improvement in the case of Manual lens with different crop factor
  • Image size was different from original RAW image size after importing to TS
  • Olympus OM-D E-M1 images was rendered with a darker column on the right side of the image
  • Auto Lens correction was incorrect on Fuji Raw files.

1.1.5 Cumulative Update

August 23, 2017

Update v1.1.5 is a Cumulative Update, bringing our work on the beta version of Studio 1.1 to the public. The following is a summary of the changes made through v1.1.x updates, which includes a new GUI!

  • Clarity in Studio
  • Transparency support
  • ReMask 5 as a plug-in in TS
  • Motion Blur Adjustment
  • Notification Center
  • Added a way to refine the edge of a created mask
  • Image layer can be foreground and background
  • Hue and Lumnosity mask selection using location picker
  • Global mask now has an Eraser mode
  • Added a green circle to indicate the reach of the spot masking control
  • New GUI
  • Workflow panel replaces list of tags (All, Featured, Trending, etc.)
  • Moved Copy/Paste Adjustments options to bottom of Adjustment Panel (bottom right corner of application)
  • Adjustment list moved from canvas to top of Adjustment panel
  • Tools moved from canvas to top of Workspace panel (bottom center)
  • Moved Download Manager to Notification Center
  • Zooming in/out now follows the mouse cursor

You can see the changes here:

Before

gui_before.png

After

gui_after.png

Before

workflow-panel-before.png

After

workflow-panel-after.png

Before

copy-paste-before.png

After

copy-paste-after.png

Before

tools-list-before.png

After

tools-list-after.png

Before

adjustment-list-before.png

After

adjustment-list-after.png
  • Prevented use of "Save" button when editing RAW file in Standalone Mode (Cannot write to RAW)
  • Studio would loop endlessly when attempting to open items that are no longer available, in the Recent File menu.
  • Users could not install to a folder if they already have TS installed in the same folder.
  • Shadow Recovery affected mid-tone as well as Shadows
  • Highlight and Contrast sliders in Basic Adjustment affected the Contrast
  • TS were not installed as plugin in PS that are not in default location on Windows
  • Studio did not switch to My Effects panel after creating a preset in some cases
  • Topaz Studio not working - KERNELBASE.dll exception
  • Could not import transparent assets into texture adjustment
  • When opening a grayscale image, the program became not responsive
  • Fixed Banding artifacts with the HDR preset
  • HSL default sometimes had tone on it
  • Black and White adjustment created strong artifacts
  • Improved Spot selection color aware feature
  • Improved gradient selection color aware
  • Corrected rounding issue when typing in slider values

1.1.6

August 25, 2017
  • Added support for graphics cards with > 8GB of RAM
  • Added “Save” and “Exit” buttons to the bottom right hand corner of the application
  • Saving an image no longer opens the file dialog
  • Added Black/White buttons to the Mask Transparency slider
  • Mask Transparency and Hue/Luminosity sliders are now persistent
  • The notification center can now be accessed before opening an image
  • Fixed banding caused by Radiance adjustment
  • Color Theme adjustment no longer shifts colors when zooming in/out of an image
  • Opening an image with transparency in the standalone version no longer causes strange results
  • Fixed several mask related bugs

1.1.7

This is a bugfix update

August 28, 2017
  • Disabled Impression workflow and presets
  • Save button not disabled when there is no image or no change to image
  • Adjust 5 was missing in TS plug-ins list

1.1.8

This is a bugfix update

August 29, 2017
  • Fixed the Clarity ownership validation issue
  • Fixed the plugin missing from Topaz Studio plugin menu issue

1.1.9

This is a bugfix update

August 30, 2017
  • Added Clarity presets in the distributed database
  • Disabled update manager in Photoshop Plugin mode

1.2.5 Cumulative Update

September 14, 2017

Update v1.2.5 is a Cumulative Update, bringing our work on the beta version of Studio 1.2 to the public. The following is a summary of the changes made through v1.2.x updates, which includes Impression in Studio and Topaz Studio Project (.tsp) files!

  • Impression in Studio
  • Topaz Studio Project (.tsp) files!
  • Added Impression in Studio Photoshop Plugin
  • User-created Impression 2 presets are loaded in Topaz Studio
  • Added the Painting Progress control to change the number of passes when using Impression
  • Added White Balancing tool in Basic Adjustment
  • User can use ellipse tool to rotate Swirl Blur
  • Made the mask button on each adjustment more obvious
  • Improved Texture Adjustment GUI
  • Removed background from Invert button in Texture Adjustments
  • Made the Save Effect, Adjustment Menu, and Reset button icons the same size
  • Added styles to Precision Contrast sliders.
  • User preference for workflow view is remembered.
  • Improved the ways presets are sorted and displayed in each category.
  • Show informative message if the user clicks on a user related tag but has nothing in that tag.
  • Moved Preferences menu option to Edit menu on Windows
  • Changed Vignette Strength slider default value.
  • Removed several effects in the application with no names.
  • Miscellaneous spelling correction.
  • Fixed the issue where Softness Slider on the brush masking tab jumps to the default value when brought below 0.1
  • Fixed Color Theme adjustment crash issue.

1.2.6

September 14, 2017
  • Corrected Validate Plugins process for Impression

1.2.7

September 15, 2017
  • Corrects issue that prevented Impression from showing in the Specialty Workflow area

1.2.8

September 19, 2017
  • Improved speed of preset thumbnail generation for Impression in Studio
  • Added the Impression Workflow Preset
  • Added Impression adjustment-level presets
  • Texture Names were missing in Impression Adjustment
  • Removed Get Pro Pack item from Adjustment menu
  • Added overlay for HSL Color Tuning in Impression in Studio

Studio 1.3.x

v1.3.2  v1.3.3 v1.3.4

1.3.2

September 28, 2017

Update v1.3.2 is a Cumulative Update, bringing our work on the beta version of Studio 1.3 to the public. The following is a summary of the changes made through v1.3.x updates, which includes Detail in Studio and features the return of Subcategories!

  • Ported Detail plugin as (Precision Detail and Channel Mixer adjustments)
  • Added an effect info pop-up
  • Added HD Preview button to view the final output of the image
  • Added “Apply To All” checkbox to the save warning dialog
  • Added preference for default save file format for RAW images
  • Added preference to move the opacity and blend mode inside the adjustment instead of in the adjustment header
  • Added a button to change the background canvas color
  • Added icon for the Channel Mixer adjustment
  • Auto adjust for lightness channel in the Channel Mixer adjustment
  • Add black and white point tool to Detail Adjustment
  • Image Layer enhancements now supported
  • Precision Detail adjustment level presets added
  • Channel Mixer adjustment level presets added
  • Updated the look of the zoom slider
  • Sort Texture Categories alphabetically
  • Removed “Download” category from the Texture adjustment
  • Updated the button configuration in the masking panel
  • Added gradients to several sliders
  • Auto load the transform tool when image is loaded into image layer adjustment
  • HD preview stays on now when switching between images or projects
  • Add sub categories to Clarity, Detail, and Impression
  • Update notification center to grab content from version seed (1.2, 1.3, etc)
  • Reset Mask, Copy/Paste Mask, Invert Mask, Alpha Mask, and Hide Mask options moved

You can see the changes here:

  • Removed duplicate “My Textures” category from the Texture adjustment
  • Set 0.01 as the minimum value for the Color Mask Range and Luminosity Mask Range sliders in the masking panel
  • Reset sliders on double click implemented for the Precision Detail adjustment
  • Detail ownership validation
  • Fixed scaling in swirl blur when ellipse is rotated
  • Improved startup time with improved adjustment sync process
  • Fixed incorrectly sized smaller preview during Heal and Lens mode
  • Fixed HD preview at 100% zoom
  • Fixed preview losing preset adjustments after Heal or Lens Correction tool is used
  • Color Theme Adjustment color picker is in grayscale instead of full color

1.3.3

October 2, 2017
  • Correct issues preventing some Mac users from seeing the Subcategory dropdown in Specialty Workflows (Impression, Detail, Clarity)
  • Fixed the issue of preset sub-categories missing if directly invoked from PS.

1.3.4

October 3, 2017
  • Precision Detail (all sliders) at high strength created halo.
  • Precision Detail selection was not consistent for what constitutes overall, shadow or highlight.

Studio 1.4.x

v1.4.2  v1.4.3 v1.4.4

1.4.2

October 13, 2017

Update v1.4.2 is a Cumulative Update, bringing our work on the beta version of Studio 1.4 to the public. The following is a summary of the changes made through v1.4.x updates, which includes the new and free Text Adjustment and features the addition of a Topaz-only Filter! You will also no longer need to duplicate your background layer, to use Studio as a Photoshop plugin.

  • PS users are no longer required to duplicate layer before invoking TS
  • Added Text Adjustment (free)
  • Added Black and White level controls in Precision Detail Adjustment
  • Added black/white point slider and pickers in Basic Adjustment
  • Added preference for default save file format for RAW images
  • Added temp and tint color pickers in Basic Adjustment
  • Only Topaz and user created presets are shown by default, added a preference option to show presets from Community
  • Simplified Help menu items, consolidated Validate Plugins, Sync Adjustments and Import Effects into Check For Updates
  • Show toast messages when the user purchases one or more adjustments
  • Improved the speed of Impression preset rendering issue
  • Users can now use Topaz Studio from Affinity
  • Pressing the “HD Preview” button no longer flashes an image on the screen
  • Fixed masking coordinates for enhancements on Image Layer adjustments
  • Handles on gradient mask can now be selected anywhere in the workspace (including outside of the image preview)
  • Copying and Duplicating the Motion Blur adjustment now copies the size of the Motion Blur

1.4.3

October 17, 2017
  • Removed white borders from image while masking
  • Application does not download high resolution textures until prompted by the user
  • Image Layer adjustment can be larger than the input image again
  • Improved synchronization reliability

1.4.4

October 19, 2017
  • Fixed the issue where the initial launch of the application went out of screen on windows.
  • Fixed the issue with the Check For Updates menu option not displaying the software update info.
  • Fixed the issue of incorrect URL used for checking for updates.
  • Fixed the issue of Impression and Detail not showing up on new installation.
  • Fixed the login issue for users with no owned products.

Studio 1.5.x

v1.5.2 v1.5.3

1.5.2

October 26, 2017

Update v1.5.2 is a Cumulative Update, bringing our work on the beta version of Studio 1.5 to the public. The following is a summary of the changes made through v1.5.x updates, which includes: Simplify in Studio, along with two new Adjustments - Quad Tone and Edges!

  • Added Simplify in Studio (Basic Adjustment, Abstraction, Edges, Quad Tone, & Vignette!)
  • Added Quad Tone adjustment
  • Added Edges adjustment
  • Added "Use Original Image As Input" (as opposed to using the output of the previous adjustment) menu item to the adjustment menu
  • For first time users, Display the initial configuration progress in the Product Tour
  • The first undo point now works after opening a .tsp file
  • The first undo point now works after duplicating an image
  • Text adjustment no longer stuck at 0.01 Text Size
  • Text adjustment shows correctly in the HD preview
  • Effect blend mode label(only) persists after applying any preset
  • Texture Adjustment size resets when hovering over a different texture asset
  • Lightroom saving has been improved for cases where apply or duplicate is used (This is a long awaited fix for LR users)
  • Color pickers in Basic Adjustment do not work with undo/redo
  • Topaz Studio crashes when clicking an applied image after the applied image is dragged into the adjustment panel as a new image layer

1.5.3

October 31, 2017
  • Login timeouts now provide an error message, instead of hanging perpetually
  • Cannot use Studio or "in Studio" plugin products more than once in Photoshop
  • Intel GPU crashes when using the Edges adjustment (presets, adjustment, workflows)

1.6.7

December 14, 2017
  • Glow added to Topaz Studio as a workflow. Learn more  
  • All Glow 2 presets are available in Topaz Studio
  • You can now move the asset folder (tgrc) to a custom location [Help → Move Downloaded Resource Files]
  • We now show you database sync progress
  • We updated the effect panel design:
    • Workflow panel redesigned to show subcategories
    • Sorting options added
    • Show/Hide Community effects option added
    • Workflows have been reorganized
  • We updated the Product Tour slides
  • We sped up the program startup time by 50%, compared to v1.5.3
  • We added a Preference option to save canvas color
  • We added a Preference option for Apply behavior
  • We added a Preference option for Duplicate behavior
  • We added Canvas Color & HD Preview to the View menu
  • We moved the Invert Mask button out of the menu
  • We have split the Check for Updates option into two:
    • Check for Adjustment Updates: this option will check to see if you have any free product upgrades available, like Glow in Studio or Clarity in Studio, from the previous version.
    • Check for Application Updates: this option will check to see if the Topaz Studio application has any updates available.
  • We have improved the interface in the HSL Color Tuning Adjustment:
    • New tabs for Color, Hue, Saturation, and Lightness
    • Improved color manipulation tools
  • We fixed many database sync issues
  • We fixed the Impression brush and canvas file missing issue
  • We fixed the garbled text on GUI for Mac users
  • We fixed an issue where the application would resize and jump back to the top left corner issue on Mac, which also impacted full screen mode
  • We fixed the application window defaulting to primary monitor on Windows
  • We reduced number of syncs to Topaz Studio server
  • We fixed Check for Updates errors
  • We fixed Studio always saving at 72DPI, regardless of preference
  • We added block to prevent PSD files from being sent from Lightroom to Studio (PSD not supported)
  • We fixed broken search tags
  • We fixed File menus not working on first time launch
  • This update fixes Glow black output problem on low end GPUs, by moving into Topaz Studio
  • We fixed an issue where text can be cut off in the notification panel
  • We fixed an issue where an image remains on screen after using Close All
  • We fixed issues related to Download High Resolution Textures option

1.6.8

December 15, 2017
  • We fixed a bug that caused imported textures to "go missing", due to use of new Assets (tgrc) folder location
  • We fixed buggy scroll behavior on Macs
  • We fixed a sync issue that impacted product updates, adjustment purchase sync, and login, caused by an issue with the user account

1.6.9

December 18, 2017
  • We fixed a bug that prevented some Clarity effects from showing up
  • We fixed a bug that prevented Drag-and-Drop Open method from working on Mac

1.6.10

December 21, 2017
  • We fixed more issues with synchronization
  • We fixed a problem that prevented Studio from launching on some Macs
  • We fixed a problem that occasionally caused a long load time for Studio
  • We fixed a problem that would cause the update to hang/freeze for non-admin user accounts on Windows

1.6.11

January 2, 2018
  • We fixed a problem that prevented new users from logging into the application:
    • We fixed a problem caused by the above login issue that prevented access to the application menu items
    • We fixed a problem caused by the above login issue that prevented access to presets in the application
    • We fixed a problem caused by the above login issue that prevented activation of purchased Pro Adjustments

Studio 1.7.x

v1.7.6

1.7.6

January 18, 2018
  • We upgraded the Studio installer, making it significantly faster.
  • Texture Effects has been added to Topaz Studio!
  • Topaz-created Texture Effects presets are now available
  • We have made some tweaks to the image processing engine to begin addressing black output for some users. If you're still seeing solid black images when you save from Topaz Studio, after updating to 1.7, let us know!
  • We fixed a bug that saved all images at 8bit color depth, no matter what setting was used.
  • We fixed a bug related to Sony ARW files that caused Topaz Studio to crash.
  • We fixed a display/scaling bug in the Save Effect Dialog

Studio 1.8.x

Introducing

1.8.5

March 20, 2018
  • We have added the Digital Frame Adjustment!

1.8.4

March 2, 2018
  • We have enabled the SAVE button following the use of Apply/Duplicate/Plugin
  • We fixed a bug that made TIFF files unreadable if saved from a DNG file
  • We fixed an alignment issue with the AI ReMix adjustment
  • We fixed a problem with SAVE when in Lightroom External Editor mode
  • We fixed a bug with database synchronization that caused AI ReMix thumbnails to be blank for some users
  • We removed a duplicated lensfun database folder

1.8.3

February 27, 2017
  • We added more AI ReMix models! There are now 50 total
  • We fixed an issue that caused update notifications to appear when no updates are available

1.8.2 

February 26, 2018

Update v1.8.2 is a Cumulative Update, bringing our work on the beta version of Studio 1.8 to the public. The following is a summary of the changes made through v1.8.x updates, which includes the new AI ReMix adjustment.

  • We added the AI Remix adjustment! Learn more by clicking the button directly above
  • We added opt-in application logging into the Help menu for troubleshooting purposes
  • We have officially added host editor support for Serif Affinity Photo
  • You can now edit the name of the image you're working on in the Workspace (bottom) panel
  • We improved the performance of the Windows GUI
  • We split tgrc (assets folder) into multiple packages to prevent extraction errors some users encountered while installing a large resource folder
  • We now allow you invoke Save or Save As after changing the image size (without using any adjustments)
  • We improved the overall start up process on both Mac and Windows
  • We fixed an issue where a non-default tgrc (assets folder) location was not being used by installers, which caused missing assets/resources
  • We fixed an issue where pressing spacebar will not toggle original and processed
  • We fixed an issue where using Save All caused the program to hang when encountering images with no edits applied
  • We fixed a scaling/interface issue that occurred after install, on first run, for users with a high DPI display
  • We reduced synchronization errors that were causing a hang on program startup
  • We fixed a banding issue when adjusting lens settings on some RAW files
  • We fixed Save/Save As changing the default image properties when saving back to Lightroom
  • We fixed an issue with tool panels not disabling asset selection in adjustments hidden underneath the tool panel
  • We fixed an issue with the save effect dialog not scaling properly
  • We fixed an issue where Texture Adjustment resources were not downloading correctly, showing incorrect percentages on thumbnails
  • We fixed a Windows 7 Enterprise incompatibility with VComp.dll
  • We reduced halos in the Precision Detail adjustment
  • We removed an unused Lightroom link file for Mac

1.9.3

April 13, 2018
  • We have changed the JPEG default Quality value to 10
  • We refined the Save As dialog to look better
  • We have updated error messages produced during file saving to be more informative
  • We fixed a bug with Save As that strips the lowest level directory when changing the file name and pressing Enter
  • We fixed a bug that caused lower quality JPEG saves to lose color
  • We fixed a bug that caused Studio to crash when saving from TIFF to JPEG

1.9.2 

April 9, 2018

Update v1.9.2 is a Cumulative Update, bringing our work on the beta version of Studio 1.9 to the public. The following is a summary of the changes made through v1.9.x updates

  • We added more save options!
  • We have re-worked Lightroom editing to officially support sequential image load on Mac and Windows!
  • We changed the default Compression/Quality value for PNG and JPEG, respectively, from 5 to 10
  • We have fixed a problem in Lightroom that caused images returned to the catalog to display various errors (does not show in catalog, flashes, fails to render, etc.), due to an incorrect colorspace value being returned to Lightroom! This was a pesky one!

1.10.5

May 3, 2018
  • We reduced the size of the text on AI ReMix models, so they fit in their thumbnail area
  • We fixed a crash that resulted in an empty output file when using Save As to create a PNG in the sRGB colorspace
  • We fixed a problem that caused Studio to hang after trying to open a corrupted image file

 1.10.4

May 1, 2018
  • We added Batch Processing!
  • We added 24 new style models to AI ReMix
  • We added names for all AI ReMix style models
  • We added sticky settings for the Save As dialog
  • Topaz Studio now highlights the file name when saving
  • We fixed a bug related to TIF interleaving settings that caused TIF/TIFF files to open slowly
  • We improved the save quality for output JPEG files
  • We corrected a problem that prevented a preview from showing when opening small images
  • We corrected a problem with the swirl blur option in the Motion Blurs Adjustment that caused incorrect rendering when flipped
  • We fixed a bug with the zoom feature, caused by specific overlays
  • We fixed a bug with masking where mask is no longer correct, caused by flipping your image

1.11.8

July 23, 2018
  • We fixed an issue with product sync that was caused by texture import. This should address many of the sync problems users have been encountering

1.11.7

July 10, 2018
  • We changed the name of the AI Clear "Strength" slider to "Recover Details" to more accurately represent what this slider does
  • Recover Details slider has been inverted -- as the value increases, detail removed by AI Clear will be added back and the effect will be reduced
  • We have renamed the AI Clear "Detail Boost" buttons to "Model Strength"
  • AI Clear Model Strength: Low, Medium, and High now represent their own models. Use Low and High options for Luma noise
  • We fixed an issue related to zooming while using the brush mask that would cause the brush cursor to expand endlessly

1.11.6 (Unreleased)

No release
  • We added two new models for AI Clear, to replace the Detail Boost/Model Strength options, to help with Luma noise in images

1.11.5

June 20, 2018
  • We changed the preset panel to only show Topaz Labs presets by default. Click the "public" icon to see all presets including those from the Community
  • We fixed a problem where some effects were missing due to a pagination error
  • We fixed an issue with Adjustment Purchase Sync that was impacting some users

1.11.4 

June 14, 2018
  • We added the AI Clear Adjustment! Learn more by clicking the button above
  • We added resizing options in the Batch Processing feature
  • We added the ability to open PSD files (Requires compatibility mode)
  • We added thumbnails to your TSP files!
  • We have added true progression in the processing/progress bar!
  • We have changed the default batch Save As file format to JPG
  • We have changed the default batch Save As colorspace to sRGB
  • We have added a warning dialog that will show when you try to open a file with invalid image data, or that is in an invalid format
  • We have added a progress indicator for TSP file saving and opening
  • We have made Batch Processing file save options "sticky" so they remember your preferences
  • We have changed batch processing Source and Destination folders to default to the path currently displayed, speeding up navigation to photo location
  • We have changed the default Save As location to the folder where the image was opened
  • We fixed a problem with files that caused them to be deleted when the file name was changed outside of Studio, and an invalid character is in the file name
  • We have fixed a problem with the Black/White point color pickers that set the chosen value to all Basic Adjustments present on the image
  • We have fixed a problem with Save that increased saturation, which did not impact Save As
  • We fixed an error where zooming in too far can cause overlay tools to disappear
  • We made another attempt to fix the flipped mask results in incorrect preview issue
  • We fixed a problem with the Motion Blur - Swirl related to flipping the adjustment
  • We have implemented a new fix for Windows users with multiple monitors losing the Studio application window, preventing access
  • We fixed a problem with file format choice defaulting to TIFF, even if JPEG or other was selected, in Batch Processing when you select the Output Folder for the first time.
  • We fixed an issue with resizing that caused the image size to be off by 1px
  • We fixed an error where duplicating an Enhancement did not copy the mask
  • We fixed a problem that prevented you from copying and pasting masks from Enhancements

1.12.6

October 23, 2018
  • We improved the backend image processing speed and quality for A.I. Clear
  • We improved the A.I. Clear models for a better result
  • We added Low and High sharpness options to A.I. Clear
  • We added intelligent noise detection to A.I. Clear (Auto, now applied by default)
  • We reduced the initial sync time
  • We added two new buttons to the interface in the A.I. Clear Adjustment for the new sharpness controls
  • We added more fixes for the Digital Frame "ghosting" effect seen in some images.

1.12.1 - 1.12.5

Internal Release

1.12.0 

September 20, 2018
  • The application will now show a toast message when syncing starts/finishes
  • We added a generic text field to Batch Processing file naming options (for suffix and prefix text)
  • The application will now show pixel dimensions when cropping
  • We reduced the sync computation time!
  • We improved error handling when there is no network connection
  • We removed unused resources in database
  • We fixed a problem with texture import when importing grayscale images
  • We fixed the incorrect overlay behavior in Focal Blur
  • We fixed a problem with window control restore down settings being lost on exit, after the user Maximizes the window
  • We fixed a problem where the Save button is inactive immediately after the application of a plugin
  • We fixed reported TIFF color profile issues
  • We fixed crashing on Digital Frame for some users
  • We fixed a problem that caused a color shift when saving back to LightRoom
  • We fixed a problem where the Save As dialog would show sRGB, but instead output images as ProPhoto color profile
  Notice: User Preset backup and sync has been disabled in Studio 1.13. We are improving the overall system, and this change was necessary to make that happen. We will notify all users when User Preset sync has returned. When we re-enable the feature, all new user presets that have been created will be correctly synced.
~Topaz Labs Team

1.13.2

December 11, 2018
  • We have added 39 new assets to the Texture Pro Adjustment, by Hazel Meredith

1.13.1

November 14, 2018
  • We fixed a problem impacting the A.I. ReMix adjustment-level presets
  • We fixed an issue with custom asset (tgrc) folder locations that prevented Impression brushes from syncing correctly
  • We fixed a problem with A.I. Clear ownership sync

1.13.0 

November 8, 2018
  • We added 28 new styles to the A.I. ReMix Pro Adjustment!
  • The 28 new styles will process in your GPU! Previous styles will still process using your CPU
  • We have implemented a new backend approach to Ownership and Resource sync. First install, first launch, and subsequent first launches should be much faster now
  • We have added categories to the A.I. ReMix style browser!
  • We fixed a problem with the user interface that caused panels to flicker and flash when using certain adjustments for Windows 10 users with Intel HD Graphics 500 series and 600 series Graphics Cards. The previous workaround required a driver rollback to restore functionality. You can now use Studio with the latest drivers for impacted Graphics Cards.
  • We fixed a problem that caused Topaz Studio to crash when A.I. Clear was used, for some macOS users.
  • We fixed a problem that some users experienced while using Impression, that caused a crash
  • We fixed a problem that caused Studio to show the wrong CFBundleIdentifier value on macOS
  • We fixed a problem that caused the Topaz Studio.app file to show "QTMake" for the version number in the Get Info panel in macOS. The actual application version is now correctly listed.
  Notice: User Preset backup and sync was been disabled in Studio 1.13. We are improving the overall system, and this change was necessary to make that happen. We will notify all users when User Preset sync has returned. When we re-enable the feature, all new user presets that have been created will be correctly synced.
~Topaz Labs Team

1.14.2

February 27, 2019
  • We refactored and improved the plugin support feature

1.14.1 

February 7, 2019
  • A.I. Clear will now always show up as owned when it has been purchased
  • Fixed application scaling issues. Application is now useable when resized to fit almost any size monitor with most zoom levels (very small screens < 10" with high zoom levels > 350% will still have issues)
  • Fixed Focal Blur adjustment overlay size not matching the preview blur
Was this article helpful?
101 out of 153 found this helpful
Have more questions? Submit a request
Check out our forums for more information!