Skylum Luminar 3: Using Your Topaz Labs Plug-ins

Screen_Shot_2019-05-07_at_12.01.35_AM.png

Using your Topaz Labs plug-ins with Skylum's Luminar 3 is easy. You can find them by opening an image in Luminar 3, then navigating to 'Edit>Plugins'. Some of your plug-ins may already show up here, but if you don't see them, check under the 'Other' menu.

If you do not see your plug-in under the 'Other' menu, here's how to add it.

Under the same 'Edit>Plugins>Other' menu, select 'Open Plugin...'.

Select the folder for the application from the 'Applications' folder, then click 'Open'

Screen_Shot_2019-05-07_at_12.05.43_AM.png

You may need to close and re-open Luminar 3 before your plug-in appears in the 'Plugins' menu. 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request