Topaz Studio 2 Changelog

v 2.2.0
November 7, 2019

New Features

  • 40 new Looks

Change

  • New installers

v 2.1.1
October 7, 2019

Fix

  • No longer crashes on Mac when coming from Lightroom or opening certain TIFFs
  • No longer crashes when closing or opening an image after viewing Flare presets
  • Added a missing cancel button when using the open file dialog with unsaved changes
  • Recent file menu should now go away after you select a file
  • Crop overlay will no longer stick around if you click the crop button to cancel
  • Auto-located stars moving in some cases has been fixed
  • Flare presets have been cleaned so they no longer include their own star positions
  • Flare presets will now respect your chosen auto locate setting instead of applying their own
  • Made removal of stars more forgiving, so you don't need to be as precise on large images
  • The dropdown accept option in plugin mode should now work as intended

v 2.1.0

October 2, 2019

New

  • New Flare filter has been added with Star tool
  • Filter level presets now display a thumbnail and work similar to Looks
  • Added a reset button to the top right of the cropping panel
  • There's now a button to swap between landscape and portrait aspect ratios in the cropping tool
  • Brush mask can now be toggled so you can drag and mask easier
  • Some dialogs for close confirmation now have a cancel option for when you change your mind

Change

  • Mask and filter panels no longer stay open when cropping panel is opened
  • Sliders should now reflect what value they're at
  • Save look button is now inactive if there have been no changes
  • Filter level presets have been moved to their own dedicated section below the filter control panel
  • You can now double click the crop box to apply
  • Cropping tool apply and cancel buttons have been moved to the bottom

Fix

  • Improvements to program stability
  • Images should no longer be squished when sent back to Photoshop
  • Images should no longer load in the wrong orientation
  • Users importing RAW files should no longer have them turned magenta
  • Scrolling through looks quickly will no longer crash
  • Masking a cropped and rotated image should now work
  • Input should no longer be lost when typing in values manually in crop
  • Filter layer icons should no longer disappear when resetting a filter

v 2.0.13
September 23, 2019

Change

  • Updated Splash Screen Image

Fix

  • Fixed Topaz Studio 2 Lightroom Preset will now launch Studio 2 as expected.

v 2.0.12
September 3, 2019

New

  • Added plugin support for AI products
  • Added inches, centimeters, and millimeters options to both resize and crop
  • Added lock functionality to cropping

Change

  • Updated style across the app
  • Changed "Stain Glass" look to "Stained Glass"

Fix

  • Fixed aspect ratio of mask on filters
  • Fixed collapsed tabs resetting when switching between menus
  • Fixed look panel overlapping crop panel
  • Fixed color theme style

v 2.0.10
August 13, 2019

Fix

  • Fixed bug where images would be blurry when imported from Photoshop
  • Fixed controls being dragged inside the sidebar on touchscreen devices
  • Fixed Text filter's box from getting stuck in some situations
  • Fixed Text filter acting strangely when given no text
  • Fixed resizing after a crop bringing in the wrong dimensions
  • Fixed rotation hint arrows on crop pointing the wrong way

New Feature

  • Added basic Wacom tablet/stylus   support for windows users

v 2.0.9
August 9, 2019

Fix

  • Fixed sliders not updating to the values they were dragged to
  • Fixed previews being wrong after cropping
  • Fixed the texture manager hover boxes sticking in some cases
  • Fixed search textbox not being focused when searching for a look
  • Fixed masking being off after cropping
  • Fixed image view being off after cropping
  • Fixed some textures showing up as black boxes due to missing resources

v 2.0.8
August 8, 2019

New Feature

  • Added bulk import for textures
  • Added ability to edit texture names in the texture manager
  • Added multi-select deletion from texture manager

Fix

  • Fixed text filter leaving behind edit box when deleting the layer
  • Fixed text overlap issues in texture browsers
  • Fixed transparent textures having a shadow of the base image on them

v 2.0.7
August 7, 2019

New Feature

  • Crop/Rotate/Straighten added
  • Added ability to manage textures
  • Image Navigator added

Change

  • Save as Project File in Photoshop or External Editor mode from File Menu

Fix

  • Corrected Issue with scrolling to bottom controls in Filter Panel
  • Corrected issue wehre the mask brush would linger after masking, closing, and opening new image

v 2.0.6
August 5, 2019

New Feature

  • Tools menu added with a Toggle Histogram option - more tools to come
  • Ability to Create, Import form TS1, Use, Remove Custom Filter Presets
  • Names have been added to textures
  • Name Search in Texture, AI ReMix, and Digital Frame added

Change

  • Increased histogram brightness
  • Histogram has been relocated to the right side of the bottom tool bar

Fix

  • Fixed issue preventing tiff files from opening on windows machines

v 2.0.5
August 1, 2019

New Feature

  • Histogram is now available
  • Filter Presets are now available
  • TS1 Custom and Favorite Effects can now be converted to TS2 My Looks (can be run more than once, overwrites any look in My Looks with the same name)

Change

  • Updated UI in Filter control panels to not clip top control

Fix

  • Fixed issue where sometimes a recent filter would not add to the effect stack when clicked

v 2.0.4
July 31, 2019

New Feature

  • Add Filter Panel now remembers last viewed state (Filters, Favorites, Recent) 
  • Add Look Panel now remembers last viewed state (category, sort, thumbnail size)
  • TS1 Custom and Favorite Effects can now be converted to TS2 My Looks (can be ran more than once, overwrites any look in My Looks with the same name)

Fix

  • Fixed a UI bug where "Effects" in the Add Filter Panel should be called "Filters"

v 2.0.3
July 30, 2019

New Feature

  • Added Reduce Noise Filter
  • Added Ability to Copy and Paste a Mask
  • Added Search by Look Name
  • Focal Blur Rememberance and visual fixes

Change

  • No longer displays blue and spinner when processing slider changes in Photoshop Mode 

v 2.0.2
July 29, 2019

Fix

  • Fixed crash on export or saving back to host editor for TIFF images.

New Feature

  • Tool to migrate your personal presets from Classic Studio into Looks in Studio 2 has been added to the Help Menu.
  • Brightness/Contrast Filter has been added to the list of Filters

Change

  • Filter Favorites List is now sorted alphabetically within categories.

v 2.0.1
July 26, 2019

Fix

  • Fixed bug where opening the app via an associated .ts2 file on mac would open in external editor mode.

v 2.0.0
July 24, 2019
Topaz Studio 2 Initial Release

Was this article helpful?
5 out of 5 found this helpful
Have more questions? Submit a request
Check out our forums for more information!